Router Basics



Router Architecture
Basic Components



Router Architecture
Operating System (Cisco IOS)



Router Architecture
Four Memory Areas



Router Architecture
EEPROM (Flash)



Router Architecture
NVRAM



Router Architecture
RAM



Router Architecture
ROM



Router Architecture
Network Interfaces



Connecting and Using
Connecting to the Router



Connecting and Using
Connecting to the Router User Access Verification

Password: xxxxxx
RouterName>



Connecting and Using
User EXEC Mode



Connecting and Using
Privileged EXEC Mode Example:

RouterName> enable
Password: enable-password

RouterName#

(Note the change in the command prompt)



Connecting and Using
Privileged EXEC Mode Example of global config command:

RouterName> enable
Password: enable-password

RouterName# config
Configuring from terminal, memory, or network [terminal]?
Enter configuration commands, one per line. End with CNTL/Z.
RouterName(config)# hostname NewRouterName
NewRouterName(config)#


Connecting and Using
Changing modes Example:

RouterName(config)# CNTL-Z
RouterName# disable
RouterName>



Connecting and Using
Exiting the Router



Using the router
Looking at the setup

RouterName#show startup
Displays the configuration contents of NVRAM
RouterName#show running
Displays the currently running configuration from RAM
RouterName#show interface
Displays the status and complete info about each of the network interfaces



Using the router
Show configuration example:

(Note this is Privileged EXEC mode)
RouterName#show startup

Using 815 out of 7506 bytes
!
version 12.0
service config
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterName
!
enable secret 5 $1$XYg0$smBtuyAdUNy9253uFxiA.
enable password xxxxxxx
!
ip subnet-zero
no ip routing
!
!
!
!
interface Ethernet0
 ip address 192.168.223.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 --More--
---hitting the space bar here will display the next page---



Using the router
Show configuration example (Continued):

no cdp enable
!
interface Ethernet1
 no ip address
 no ip directed-broadcast
 no ip route-cache
 shutdown
 no cdp enable
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip route-cache
 shutdown
 no fair-queue
!
ip classless
no ip http server
!
snmp-server engineID local 00000009020000D058A39EEF
snmp-server community xxxxxxxx RO
!
line con 0
 transport input none
line 1
line vty 0 4
 password xxxxxxxx
 login
!
end


Your output will vary according to your configuration, of course.



Using the router
Show interface example:

(Note this is Privileged EXEC mode)
RouterName#show interface

Ethernet0 is up, line protocol is up
  Hardware is QUICC Ethernet, address is 00d0.58a3.9eef (bia 00d0.58a3.9eef)
  Internet address is 192.168.223.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliablility 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:28, output 00:00:08, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     5170 packets input, 633993 bytes, 0 no buffer
     Received 5170 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     44635 packets output, 5704511 bytes, 0 underruns
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
 --More--
Ethernet1 is up, line protocol is up
  Hardware is QUICC Ethernet, address is 00d0.580d.230c (bia 00d0.580d.230b)
  Internet address is 192.168.222.50/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliablility 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:02, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 1000 bits/sec, 1 packets/sec
     327340 packets input, 144892112 bytes, 0 no buffer
     Received 325241 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 input packets with dribble condition detected
     44752 packets output, 5718383 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 20 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
 --More--
Serial0 is administratively down, line protocol is down
  Hardware is QUICC Serial
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliablility 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     9403 packets output, 2900994 bytes, 0 underruns
     0 output errors, 0 collisions, 17 interface resets
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=down  DTR=down  RTS=down  CTS=down

Your output will vary according to interfaces installed.
A specific interface may be displayed instead of showing
all of them.



Getting Help
Help Features



Getting Help
Context sensitive Example #1: Config mode

RouterName(config)# ?

Configure commands:
  aaa                         Authentication, Authorization and Accounting.
  access-list                 Add an access list entry
  alias                       Create command alias
  arp                         Set a static ARP entry
  async-bootp                 Modify system bootp parameters
  banner                      Define a login banner
  boot                        Modify system boot parameters
  bridge                      Bridge Group.
  buffers                     Adjust system buffer pool parameters
  busy-message                Display message when connection to host fails
  call-history-mib            Define call history mib parameters
  cdp                         Global CDP configuration subcommands
  chat-script                 Define a modem chat script
  clock                       Configure time-of-day clock
  config-register             Define the configuration register
  default                     Set a command to its defaults
  default-value               Default character-bits values
  dialer                      Dialer watch commands
  dialer-list                 Create a dialer list entry
  dnsix-dmdp                  Provide DMDP service for DNSIX
  dnsix-nat                   Provide DNSIX service for audit trails
--more--
---hitting the space bar here will display the next page---
 downward-compatible-config  Generate a configuration compatible with older
                              software
  enable                      Modify enable password parameters
  end                         Exit from configure mode
  exception                   Exception handling
  exit                        Exit from configure mode
  file                        Adjust file system parameters
  frame-relay                 global frame relay configuration commands
  help                        Description of the interactive help system
  hostname                    Set system's network name
  interface                   Select an interface to configure
  ip                          Global IP configuration subcommands
  key                         Key management
  line                        Configure a terminal line
  logging                     Modify message logging facilities
  login-string                Define a host-specific login string
  map-class                   Configure static map class
  map-list                    Configure static map list
  menu                        Define a user-interface menu
  modemcap                    Modem Capabilities database
  multilink                   PPP multilink global configuration
  netbios                     NETBIOS access control filtering
  no                          Negate a command or set its defaults
 --More--
 
---display of output has been truncated---



Getting Help
Context sensitive

Example #2: User EXEC mode

RouterName> ?

Exec commands:
  <1-99>           Session number to resume
  access-enable    Create a temporary Access-List entry
  access-profile   Apply user-profile to interface
  clear            Reset functions
  connect          Open a terminal connection
  disable          Turn off privileged commands
  disconnect       Disconnect an existing network connection
  enable           Turn on privileged commands
  exit             Exit from the EXEC
  help             Description of the interactive help system
  lock             Lock the terminal
  login            Log in as a particular user
  logout           Exit from the EXEC
  name-connection  Name an existing network connection
  pad              Open a X.29 PAD connection
  ping             Send echo messages
  ppp              Start IETF Point-to-Point Protocol (PPP)
  resume           Resume an active network connection
  rlogin           Open an rlogin connection
  set              Set system parameter (not config)
  show             Show running system information
 --More--
---hitting the space bar here will display the next page---
  slip             Start Serial-line IP (SLIP)
  systat           Display information about terminal lines
  telnet           Open a telnet connection
  terminal         Set terminal line parameters
  traceroute       Trace route to destination
  tunnel           Open a tunnel connection
  where            List active connections
  x28              Become an X.28 PAD
  x3               Set X.3 parameters on PAD 



Getting Help
Context sensitive

Example #3: User EXEC mode, partial command

RouterName> s?
*s=show set show slip systat

RouterName>s<cr>
% Type "show ?" for a list of subcommands

RouterName>show ?

  clock          Display the system clock
  dialer         Dialer parameters and statistics
  exception      exception informations
  flash:         display information about flash: file system
  history        Display the session command history
  hosts          IP domain-name, lookup style, nameservers, and host table
  location       Display the system location
  modemcap       Show Modem Capabilities database
  ppp            PPP parameters and statistics
  queue          Show queue contents
  queueing       Show queueing configuration
  rmon           rmon statistics
  rtr            Response Time Reporter (RTR)
  sessions       Information about Telnet connections
  snmp           snmp statistics
  tacacs         Shows tacacs+ server statistics
  terminal       Display terminal configuration parameters
  traffic-shape  traffic rate shaping configuration
  users          Display information about terminal lines
  version        System hardware and software status



Getting Help
Command Completion

If the parameters needed for a command are unknown
use a following question mark for help
with the next expected input

Example #1: Config "IP Address" command

RouterName(config-if)#ip address ?
A.B.C.D IP address

RouterName(config-if)#ip address 192.168.100.5 ?
A.B.C.D IP subnet mask

RouterName(config-if)#ip address 192.168.100.5 255.255.255.0 ?
secondary Make this IP address a secondary address
<cr>



Getting Help
Command Completion

Example #2: Privileged EXEC "interface" command

RouterName(config)#interface ?

  Async              Async interface
  BVI                Bridge-Group Virtual Interface
  Dialer             Dialer interface
  Ethernet           IEEE 802.3
  Lex                Lex interface
  Loopback           Loopback interface
  Multilink          Multilink-group interface
  Null               Null interface
  Port-channel       Ethernet Channel of interfaces
  Serial             Serial
  Tunnel             Tunnel interface
  Virtual-Template   Virtual Template interface
  Virtual-TokenRing  Virtual TokenRing
 
RouterName(config)#int ethernet ?
<0-1> Ethernet interface number

RouterName(config)#int ethernet 0
RouterName(config-if)#



Getting Help
Syntax Checking

Example: Privileged EXEC Config-if "IP address" command

RouterName(config-if)#ip address 192.168.100.5 secondary

                                           ^
% Invalid input detected at '^' marker.



Getting Help
Advanced editing



Configuration Commands
Three major categories



Configuration Commands
Global Commands



Configuration Commands
Major Commands



Configuration Commands
Subcommands



Configuration Commands
Command Negation Examples:

RouterName(config-if)#ip address 192.168.100.1 255.255.255.0
Is removed with the command:
RouterName(config-if)#no ip address 192.168.100.1 255.255.255.0

To startup or activate an interface, use:
RouterName(config-if)#no shutdown



Configuration Commands
Command Merging and Superseding Examples:

RouterName(config)# hostname NewRouterName
NewRouterName(config)#

RouterName(config)#snmp-server community public
RouterName(config)#snmp-server community notpublic
Creates a result of:
!
snmp-server community public
snmp-server community notpublic
!


Cisco Router Configuration Virtual Lecture by L.Scott Freudenthal